Viewing 3 posts - 1 through 3 (of 3 total)
  • bassrun
    Participant
    Post count: 2
    #6238 |

    I’m using Anytune v.2.2.0 and iTunes 12.8.2.3 on a MacBook Air running MacOS 10.13.6.

    Over the past few days I’ve organized an Anytune playlist. I’ve also been doing some noise reduction on some files that have gone into that playlist. Noise reduction has been in iZotope RX-7, and I initiate the process by dragging the title from iTunes onto the RX-7 icon. After editing, hitting “Save” in RX-7 overwrites the existing iTunes song file.

    Now, when I attempt to play back a song from my new Anytune playlist, some of the titles are associated with the wrong song files! I suspect that there’s an index file (Anytune or iTunes) that is corrupted. When I track down the underlying song title in iTunes, the expected song plays perfectly — there is no misidentification.

    Here is more detail on what’s happening in Anytune: The expected title shows up along with the correct waveform and markers. However, the wrong song will play.

    Is there an Anytune index file that may have been corrupted? Is there something I can do to repair Anytune’s indexing?

    admin
    Keymaster
    Post count: 15
    #6245 |

    Hi,

    OK, so you created an Anytune Playlist consisting of songs in your music library (iTunes). You then use RX-7 to modify the song while in iTunes. When you play the song in iTunes it is correct, but when played from the Anytune playlist it is the completely wrong song (not just the version previous to the edit but a different title).

    Your assessment of index corruption sounds plausible. Anytune uses a unique ID first and then matches its config record by Title, Artist, Album, duration if the ID changes (usually when meta data changes). Not sure what happens when RX-7 overwrites a file under iTunes management.

    If you change the Title, Artist, Album, in iTunes after the config is created in Anytune you may need to correct the pointer to the audio file.

    In Anytune Right-Click on the song and choose Get Info,
    You can use [Change Audio File…] to select the correct audio file if things go awry.

    iTunes is funny when it comes to editing files in the iTunes folder. For example you can rename the file or even move it to a different place and iTunes will find it. RX-7 may handle this.

    Anytune could get confused when a playlist has duplicate songs. In fact iTunes doesn’t like duplicate songs in its library either. in iTunes > File > Library > Find Duplicate Items…

    I would love to be able to reproduce the problem in the lab. This would give us the best shot and finding the source of the problem and finding a solution.

    Can you please send us an email at [email protected]. This will trigger a case opening so we can pursue it further.

    In the meantime try [Change Audio File…] to select the correct audio file. Would really like to find any bugs.

    bassrun
    Participant
    Post count: 2
    #6247 |

    Your suggested fix (via “Get Info” in Anytune) worked beautifully. Thanks!

    But now I have another data point for you.

    I went into the underlying iTunes music folder, selected an mp3 files with hum, worked it over in RX-7, and saved it to the very same location. When I preview the edited file in the Finder, it sounds perfect. However, in Anytune, the first few seconds are missing. Now I’ve reindexed the sound file in Anytune, and everything is fine again.

    So the problem seems to be in Anytune. I’ll be glad to work with you to track down the source, if I can.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.