Viewing 10 posts - 1 through 10 (of 10 total)
  • Jack
    Participant
    Post count: 2
    #555 |

    Hi Sean

    I purchased IK Blueboard and your remote midi pack for anytune. I can see that the blueboard functions because, for example, when I tap on the footpedal’s button A or B, the appropriate button lights up in the blueboard app. My iPad Bluetooth, is of course on.

    However, even after checking to make sure my midi command numbers are synchronized (for example footpedal A set to midi = 003 is same as anytune’s command for Play = 003, anytune will not respond to the footpedal. Midi channel set to transmit and receive on 1.
    Any thoughts?

    Thanks a lot

    Jack

    Tony Wacheski
    Participant
    Post count: 100
    #556 |

    Hi Jack,

    We have discovered a possible issue relating to the BlueBoard and Anytune that you might be running into. It seems that sometimes if Anytune is started before the Blueboard app, then Anytune will not receive commands from the BlueBoard app. We are investigating to figure out why this is happening and hope to have a fix in a future update.

    In the meantime, try the following steps:
    1. Quit Anytune (double tap the home button, find the Anytune in the list, and then swipe it up off the top of the screen, then tap the home button).
    2. Launch the BlueBoard app and connect to the foot pedal
    3. Launch Anytune

    Hopefully Anytune will now respond to the commands.

    If it still doesn’t, let me know and I’ll pull together some screenshots and other suggestions to help make sure you’ve got the BlueBoard app and Anytune configured correctly.

    Sean.

    Jack
    Participant
    Post count: 2
    #557 |

    July 11, 2014
    Hi Sean

    Appreciate your prompt response!

    I did try first launching Blueboard followed by Anytune but that did not solve the problem, i.e.. altho the Blueboard app recognizes the incoming midi messages, Anytune still does not.

    Look forward to any other suggestions

    Thanks – Jack

    Tony Wacheski
    Participant
    Post count: 100
    #562 |

    OK. We definitely have a bug in 3.10.1 that Anytune is not receiving notifications when changes are made to the MIDI network after Anytune starts. So you will need to make sure that the BlueBoard app is running before you start Anytune. We are working on a fix. Sorry about that. 🙁

    Here is how the BB app and Anytune need to be configured. I’ve attached screenshots for how the configuration should to look. My guess is that you may have the BB app configured in Program Change Mode rather than in Control Change mode (since that is the default). Anytune responds to Control Changes not Program Changes.

    In the BlueBoard app, tap Menu and then select Settings
    Change the Mode to CTRL CHANGE

    BlueBoard Control Change Mode Setting

    Ensure the Channel number is set to 1 (it could be any of them really, they just need to match between the BB app and Anytune).

    BlueBoard app channel configuration

    In Anytune, make sure MIDI is enabled, and the channel number matches the channel in the BB app

    MIDI enabled and channel setting in Anytune

    Finally, make sure the commands are mapped the same. The default in the BB app is 000 through 003. You can either manually set those, or use the learning function to have Anytune learn the command based on the next MIDI pedal press it receives.

    Anytune MIDI command configuration

    Jack
    Participant
    Post count: 2
    #563 |

    SEAN

    YOU NAILED IT:

    “My guess is that you may have the BB app configured in Program Change Mode rather than in Control Change mode (since that is the default). Anytune responds to Control Changes not Program Changes.”

    This point will be key for Anytune users to know because of the opposite default that blueboard uses…

    THANKS!

    JACK

    Tony Wacheski
    Participant
    Post count: 100
    #564 |

    Thanks for confirming Jack!

    We will also get the startup order problem sorted out for our next update.

    Cheers!

    Sean.

    hp.maeder45
    Participant
    Post count: 1
    #4664 |

    Sorry, dear friends, with iPhone 6 it does’nt work. Midi is on, iRig BlueBoard connected to the iPhone. Settings on CTRL CHANGE.
    When I go to Anytune and choose a song, then press a button, nothing happens

    tony_anytune
    Keymaster
    Post count: 194
    #4665 |

    The BlueBoard allows you to map ctrl messages to buttons and Anytune allows you to map ctrl messages to commands and to send or listen on one or all channels.

    CC 3 is the default for Play/Pause.
    In the Blueboard App set the first button to CC 3 and the Channel to 1 *

    Note If BB and Anytune are set to All anytune will get many messages that can cancel themselves off it will play/pause 16 times and end up back at pause.

    In Anytune in Settings / MIDI

    1. Enable MIDI In
    2. Select the Channel to 1 *
    3. Tap Channel Controller and set “Play or Pause” to 3.

    Make sure that the CC values on the Blueboard match what you wan to happen on Anytune.

    mrgeeze
    Participant
    Post count: 3
    #5161 |

    This was a big help to get the Blueboard up and running.

    I now have the blueboard configured to
    Play/Stop
    Next Track
    Previous Track
    Toggle Eq on off

    I used it at a gig last night and it worked perfect.

    Now I would like to control volume.
    If I purchase an expression pedal (say the M-Audio inexpensive Ex-P) to connect to the blueboard.
    IK tells me i can send CC message to the blueboard via the expression pedal
    The question is whether Anytunes allows Master Volume to be MIDI controllable via MIDI CC messages

    From this thread

    Anytune MIDI Capabilities

    I am wondering whether this last parameter (set gain CC7) is what I am after

    Thanks

    can I map Volume Up/Down to be controlled by this?

    Thanks

    tony_anytune
    Keymaster
    Post count: 194
    #5172 |

    Yes, the last parameter CC 7 does read the value 0==mute 127=fullVolume. If you have a pedal that sends the CC7 with a range of values you should be able to control the volume as you wish.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.